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Goal

The purpose of this configuration guide is to describe the steps
needed to configure the Cisco Unified Call Manager Express (CME)
IP-PBX for proper operation with Optimum Business SIP Trunking.

Prerequisites

Please follow the instructions in the Optimum Business SIP Trunk

Set-Up Guide. The Set-Up Guide was left by the Optimum Business
technician at installation. If you do not have the Set-Up Guide, go

to www.optimumbusiness.com/SIP to download a copy.

Call Manager Express (CME)
PBX Configuration

The steps on the next pages describe the minimum configuration
required to enable the CME PBX to use Optimum Business SIP
Trunking for inbound and outbound calling. Please refer to the Cisco
CME product documentation for more information on other advanced
PBX features.

The configuration described here assumes that the PBX is already
configured and operational with station side phones using assigned
extensions or DIDs. This configuration is based on

Cisco 2901, I0S version 15.1(3)T (c2900-universalk9-mz.SPA.151-3.T.bin)
with built-in CME v8.5.



The Cisco 2901 came with two Etherent ports, GE 0/0 and GE O/1, with GE
0/0 defaults to an IP address of 10.10.10.1/248. One of these two Ethernet
ports and the Optimum Business SIP Trunk Adatpor’s LAN port 1 should
be in the same LAN segment. The GE 0/0 port and the Optimum Business
SIP Trunk Adaptor’s LAN port 1 have been assigned with IP addresses of
10.10.10.1/248 and 10.10.10.2/248 respectively. The GE O/1 port has been
assigned with an IP address of 192.168.0.1/24 and it will be used as the
PBX's LAN port for communicating with the IP phones, as well as the
DHCP server for the IP phones.

Before you can configure the CME PBX for SIP trunk services, you need to
download and install the Cisco Configuration Professional (CCP) GUI on a
Windows PC. As of this writing, CME 8.5 and CCP 2.4 are the latest software
available. If you have a problem getting CCP 2.4 to work on your Windows
PC, check the release notes (i.e.: certain versions of the Java Runtime
Environment may require certain settings in order for CCP 2.4 to work). After
CCP 2.4 has been successfully installed, connect the Windows PC to the
10.10.10.0/248 LAN segment and start the CCP GUI.
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Cisco Configuration Professional

1. From the “Select/Manage Community"” screen, enter the CME PBX
info in the first entry of the devices to be discovered.
a. Enter the PBX's IP address in the “IP Address/Hostname" field.

b. Enter the username in the “Username" field.
c. Enter the password in the “Password” field.

d. Check the checkbox next to the password field.
e. Click the “OK" button.



Enter information for up to 5 devices for the selected community
IP Address/Hostname  Usemname Password Connect Securely
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 Selected Community: New Community .Select 2 device from the table below, Use the buttons st the bottom to continue.
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address / Hostname Router Hostname Comnection Type Discavery Status

|_Manage Devices | | Delete | |_Ptesower | | Discovary Dntads | | Cancel Discovary | | Router Status

3. Click the "Yes" button.



Cisco Configuration Professional

22-3u-2010 Brovide CCP Feedback
Security Centificate Alert -

Information you exchange with this router 10.10.10.1 cannot be viewed
B or However, there is router's
security certificate.
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4. CCP has discovered the CME PBX. Click the “Configure” button to start
configuring the PBX.

Selactad Cammunity: Wew Communtty Selact a device from the table belon. Use the buttons at the bottom to continua.
| 1 rows retrieved |

B[=

1P address / Hostname Router Hostname Connection Type Discovery Status

/Flash File Management
/" Configuration Editor

./ sawe Configuration to BC

7 Wite to Startup Configuration
o Teinet

/*Reload Device

5. Navigate to “Configure”>"Interface Management">"Interface and
Connections"” to set up the GE 0/1 Ethernet port needed for the PBX to
communicate with the IP phones.

a. Select the “Edit Interface/Connection” tab to make sure the
GE 0/1 port is not in use.
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Help
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.. Interfaces and Connections
¥ (9 Interface Management

=1 . = Create Conneclion | )|

[ Energywise

@ e g add- [ Deiete @ Summary | Detals & Test Connection @ Disable
» [ Router

(3 Sacurity

» [l Unified Communications

no P address GigabitEthernet

/*Fiash File Management
£ Configuration teltor Actess Rule - inbound
|accass Rule - outbound

/*Save Canfiguration to PC \#8ar Poiicy
/* Write to Startup Configuration Inspect Rule - inbound
Pralaat Inspect Rule - outbound
: Easy VPN Remote

¢ Raload Davica Q03 policy - outbound
»Qvien 208 Policy - inhound

.|

6. Select the “Create Connection” tab to set up the GE 0/1 Ethernet port,

select the radio button for “Ethernet LAN" and then click the “Create
New Connection” button.

Cisco C

.. Interfaces and Connections

TR | creae | Edil interr

[ Eneraywise ‘ Create New Coanection

» ) Router - "

iy & Ethemat LAN
R [ Ethernet (FPPOE or Unencapsuiated Routing]
Information

Cenfigurs Etharnst LAN interface for straight
routing and 802.1q trunking

4/ Flash File Managamant

/* Configuration Editor

-/ save Configuration ta PC

4 Write to Startup Configuration
*Telnat

./ Reload Deviee

>y vien How do|:  How Do | Configure an Unsupportsd WAN terfacs?
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7. Click the “No" button from the “Enable AAA" screen.

Help
) ome Eiwowo | §% &3 () cisco Configuration Professional 'éli"”'-

“Select Community Member:
« Configure > Interface Management > [nterface and Connections.

Create Connection | Edif interface/Cannection.

Creste New Connecton

[ Erergywise

Use Case Scenario
» i Router Selex @ ennedion and dic Creste New Connedtion
> 5 Security @ Etemei LAN
» Bl Unified Communications " Etamet (FPPOE o Unsncapsuistes Routing) g__. 0%
Information G
e ot .

reuting and £02.1a trunking

e A% =r=)

i @ The Ethemet LAN wizard aliows you to aptionally enable 802.1x
Authentication on the selected LAN inferface

802 1x Authenlicaion requires AAA 1o be enatiled on tne router
Da you want o enable A&4 on the router so that you ean conflgure B021x
ol Authentcation on the LAN Interface?

/¥ Flash File Management

¥ Configuration Editor i 1

Save Configuration to PC

/" Write to Startup Configuration
o Telnat Create New Connection
./ Relead Devics

»Bview How 801" How Do | Configure an Unsupporied WAN Interface?

Cisco Configuration Professional ‘él"‘ I

Interfaces and Connecticns

wal— Create Connection | Edit interfsceiConnection

Creste hew Connecton ‘
e
Lan 2

@ Ememes Lan Layer 3 hernet Interface Configurstion

L) Energyivice
(38 Router

e —
 Emeres FPPeE o

Information

» 1 Unified Communications

Configurs Ethernet LA ugh Layer LAN interface crestion process

Ciseo CP also allows you o designate this Ethemet inferfaceLAN as a DHCF server

#Flash File Management

/¥ Conbiguration Editor
/#Save Configuration to BC

Wt t Stactup Configuration
Tainet Crete tew Cannection
Reioad Davice

Qe

9. Click the “Next >" button.
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B e | 4:0 i ;] Cisco Configuration Professional 'él.h'“’;.

Configure > >

&
.. Interfaces and Connections

| Create Connection | Ecif Inerface/Cennection

¥ B3 Interface Management

_|1nterface and Connections.
Ca— PR e d‘
» G Router
[, @ Eimarres Lan Ethernet Canfiquration
7 Emamer BFERoE o 4
P @  ConMgurs s intartace 1or SYAIGNt rOUTING

-
PORPR—, Configure this inferface for 802,10 frunking

nformaton

Straight routing cenfigures only physicsl mam interface. Mo
subinterface/VLAN can be created under this mode.

“Sava Configuratian ts PC

#virite to Startup Configuration

#Telnat Create New Connecton
o Reload Devier

»Qvien

Homdo ! Haw Do Cani

10. Enter the IP address for the GE O/1 port in the “IP address” field,
enter the subnet mask in the “Subnet mask" field and then click
the “Next >" button.

*.. Intertaces and Connections

Create Connection | Edi InlerareiConnection
Cresme hew Canseran
5 e Case Scenario
Select & conmacion
@ Ethomes LAN LAN Wizard - GigabrEthemet0/1 ﬁ‘

r

iformaton
P address 192 168.0.1
Configura Ethamet

sumetmask  TEmemE0 w4

_*Fiash File Managament

# Canfigurstion Edtar

» Sava Contiguration to PC
*Write ko Startus Canfisuration
Freinet Crete tiew Cormectod [

4/ Reload Device
sQvien How del - How De | Cof

— <8 | Not» MM!I

1. Select the radio button for “Yes" to enable the DHCP server and then
click the “Next >" button.
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[ contonrs | o | | 52 @ 0 Cisco Configuration Professional ‘élumhﬁ

> intertaces and Connections I

v 3 Interiace Management S —
Create Connection | Edit intertaceionnaction

| Intertacs and Connsctions
% Creste tew Conmecten

() Energywise ke Bebiite
L Seiect & commection
s & EmarmatLan LAN Wizard - GigabitEthemesd/L - [===)

» @il Uniied Commumeations e
Wiurot Do you wantfo enable & DHCF server on your frusted LAN
Configure Ethemet] Interface

Nete: Enabling 3 DHOP S8t o your privata natwark
allaws you Lo automatically assign reusable IP
addresses 1o DHCP clients o the nstwork

*Flash ils Managamant

Creste New Connection

Wowdel  how Do Cof

<o v | | o] |

12. Enter the starting IP address in the “Starting IP" field, enter the ending
IP address in the “Ending IP" field and then click the “Next >" button.

A"—' [ | Bsone | | o 0 Cisco Configuration Professional ';II""I'I?

&
*. Interfaces and Connections

| Create Connection | £t Intertace Connestion |

Create hew Connecton NS S
Selec  connacion ane i Crase New Cornectan
e (T ===
b -
Feemater

Enterthe IP adiress posi range ¢ the DHCP Server. Choose Startng and ending
addresses for the DHCP Pool from the nebwork/subnet that this interface belongs o
1twill enable he DHCP cllents in his network 1o lease the ip address from range
speciied by starting and ending P address

DHCF Pool |
|

Starting IP 1821688010

Ending P 192 166.0.50

#Flazh Eils Mansgemant
#Contiguratian Editor

#Save Configuration to PC

7 Wrte b Startup Canfiguration
Freieat Create tew Conneciiof

Reioad Davice

» D vien

How do | How Do | Cof

s | ﬂlm,hl

13. Enter a valid IP address for the DNS server in the “DNS Server1” field,
leave other fields as default and then click the “Next >" button.
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Cisco Configuration Professional ‘;l'

Intertaces and Connections

v B3 Router

[ Router Optians

»EaTime

» [ Router Accass

» Gaomce

»Gons
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»aan

. I
Lanar }
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[ WAAS Express

[

| Reuter Pravisioning

#Fiash Fils Management

# Configuration Edtor

/*save Configuration to °C

¥ wite to Startus Configuration
' Teinet

#Relosd Davics.

Crvate Connection | £ Inle s calConnection

Creste New Comecten — )
Selet o connecton Correcson
@ Eheme LAN LAN Wizard - GigabiEthemet0/1 an A H
s y DHCP Ophons
ntermeten
Cenfigure Ethamat Configure the DHCP parameters Iks DNS Ssrvars, Wins Serers and
Dormain Name.
DS Server1 (") 4222 WINS Servert(")
DNS Semver2r) WINS Serverzr)
Domain Name()
3 optianal fieids:

ot | o | comen] o ||

v E3interface

Cisco Configuration Professional -é|"-'f

Intertaces and Connections

1 ang Connecter
i Enargyivise

¥ 2 Rouber
L) Router Options
> Time

(G Router Accass

» 1 DHCP
[ DHS

L) Static and Dynarmic Routi
(3L
ST

et

L1aes

L WAS Expre=s

|| Rauter Provisioning

Flash File Mansgement
/7 Canfguratian Editor
/*Save Canfiguration to PC

_FWirke to Startup Canfiguration

Create Connection | E4i Interfac e Cannection

Creste tiew Comnectan -
Select 3 CONNETOn AN NS LrEMIE New Lonredtien
 EmematLAn LAN Wizard - Gigabit€themetlyL a B W
c o
Wformator. o,
Canfigure Ethemet|
Please click Finish 10 deliver 1o e router
[Selected Inlertace GigabitEhemetd/1 -

P 30aress | 192 168.0.1
Mask : 255 255 2550

DHCP Enatled tue

Starting (P 192.168.0.10

Create New Conneciiog

How Do Co

«Back

Finen | Cancat| _wa | | |

15. Click the “Deliver" button.
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% Intertaces ana Connections

B3 interface Mansgemant S ———.
2 Create Connection | Eit rieifac&/Connechon |

A-in_,,'w,,a z Create New Connectd [AN Wizard - GigabitEthernetD/1 3 -3 =
v £ Router |
Ly Rauker Options b LAN Wizard Summary
» 51 Time  Emarres EPPCE o
5 Rovter Access ' iovsiten Piease cick Fmish to deliver to e router
v E30mcP Configure Eshamst =
R [T R
4 OHCP Bindings ‘ e E‘
3 tocal Pools |
»ons ‘I‘ Delver deta commands tc the device s running config
|} Static and Dynamic Routi y -
»Gaaa [mertace Gaabrememet1 -

»EaacL

e snuscown
Ly rar o address 162 160.0 1 256286 285.0
et

fi dhep pool cep-peot

netwerk 192 166,00 268 265 265.0
4222

defaut-router 192 1680 1

osse 1

J/*Save Configuration to PC The differences between the running configuration and the startup configuration are lost whenever

FWirte ko Startup Conbguration the device is turned off,

P Talnet Greate New Connecton]

™ Save running config to device's startup config
This aperanen can tave several mnutes

#Ralond Gavice
» Qvien How dal-  Ham Do (Cof

Dewer | cancer Save s e wes | |
=ies- 3

16. Click the "OK" button.
w & 2] Cisco Configuration Professional ‘él'-"

¥ 5 Intartace Management

Create Connection | £t intertaceiCanneston |
AN Wizard - GigabitEthemetl] =
LAN Wizard Summary

Piease click Finish 1o deliver to the router

eneraywise

¥ EaRouter
) Routar Options
» GaTima

» 4 Router Access.

¥ E3oHCR
3 0HCE Bools

lmm-umm

Detiver Canfiguration to Device L

(3/0HCR Bindings
(3tocal Books
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Br ,mmml,,1 Commands Defery Status
- [
Does I ncp.
network 192 168.0,0 266 | Commena Detvery Staus
4222
defau-router 182 1620 Tor delivery
' Flash File Management lease Subming 13 commands. plesse wat
y 2o Configuraton deivered to device

¥ Cantiguration Editer
/* save Canfiguratian ta PC The differences hatues

7 Writa to Startup Configuraton the cevice is turned of

JTelnet

o Relosd Deviee

- Qien Howde ( ow Do 1o

17.  Navigate to “Configure”>"Unified Communications'>" Unified
Communications Features” to make sure the radio button for “Cisco
Unified Communications Manager Express" is selected. If not, select it
and then click the “Apply" button.
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Selact routar operating mode: Cumently Cisco Unified Communications Manager Express.

» [ Interiace Management (&) Cisco Unified Communications Manager Express
> G Router

s, ) Gatavmy (Cantigura davice 8z MGCP/H.223/51P Gateumy)

¥ (3 Unified Corms

) Advancad Telaphany Settings
» 3 Users, Phones and Exbansions () Cisco Unifiad CHE s SAST (Use in CME as SRST moda whan link bo Ciscs Uniied Communication Manage is done)
vere sasiogs | home (Erase 3l the vaics canfiguratian on the davice)
L Trunia
» (4Dl Dlans
» L Tolaphony Features
) Media Resources

[ unified Communications Security Audit

o Flash File Management

7 Canfiguration Editor

*save Configuration to PC

o wirte to Stanup Configuration
& reinet

o/ Reload Deviee

- Qvien

Navigate to “Configure'>"Unified Communications">" Telephony
Settings" to configure the general settings.

a. Select 35 users"” from the drop-down list of the “Maximum
number of Phones” field.

b. Enter the number of extensions needed in the “Maximum
Number of Extensions” field.

c. Select the date format in the “Date Format" field.
d. Select the radio button for the “Time Format” field.

e. Select the IP address for the GE O/1 port from the drop-down
list of the “Phone Registration Source IP Address" field.

f. Enter 9" in the “Secondary dial-tone digit"” field, leave other
fields as default.

g. Click the "Apply" button.

Help
B | | S & O Cisco Configuration Professional ';L"-

Belect Community Member:
€ Configure > Unified ications > Telephony Settings

Cisco Communications Manager Express version: 8,5

Maximum number of Bhones * | 35 usars v

Maximum Mumber of Extensions *: ] number {1-200; no default)
Date Farmat | ey .

Time Farmat: (8 12 hour () 24 howr

L Advanced Telaphany Settings

» [ Users. Phones and Extensions. Fhone Regisration Source 19 Address *: 192.168.0.1 (GigabitEthernet0/1) | v

L vorP Settings

pe Secondary diai-tone digit: 5
b G Trunks
» (4 Dial Plans |
» 4 Telephony Features

L] Medis Resources

] Unified Communications Security Audit

Seftkeys Settinas

e —— Emasle FXO hosk fiach for zafticey templates: g

*Coniguraton Edter
*Sewe Configuration to PG
o Wite o Startup Configuration

Enable hunt group logout (Hisg) for softicey tempiates: | |

S Telnet
*Raload Davice S ndewtes o reviis fukd
-Gy view
o | Aeply

1
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19. Click the “No" button.
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Tume formet SETTEISE ST
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Saandary 4o sone dga . Canfirmation

M Neys ertings
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rania humt grop gt (weg ) loe sckmy teonpates

¥ () Cisco Configuration Professional alale

Select Community Mambar

% Configure > Unified Communications > Telephany Settings G

General Settings
- Cimes Communications Mansger Expreas version: 8.5
| » G Intarface Management

Maximum numBsr of Phones * [ -
b+ i ncuter aximu bar of Shones | 35

» 3 secunty Maximum Number of Extensions * P umber (1-200) no defaut]

¥ @ Unified Communiestions

i o Date Forma r——t = |
[l it Cormunieabions Fashurss | vy
|
i Tabmany setmas R ——— B i haer (D) 34 howe
[T p———
Phne Sgisiation Scuce # Addvasa >

» B Usars, Shanes and Esaarsicas 192.100.0.1 (Ggabisthernero/1) | v |

L3 Volm Sattings

Secondary diai-tone digh s
» CaTrunis
» @0l Blans _ ‘

3 Telephony Features

L) Medis Rescurces " Followng commands wil be assied to the device 3 runnmg conhguration. ‘

) Unifiad Communications Security Aud P ——

P source-addross 182.168.0.1
mase-dn ¢

create cnt-filas

exit

SoftKeys Settings

Enabie FXO hook fRash far s
*Canfiguration Editor

Enabie hunt grous logout ()

Save Configuraton ta BC

Write to Startup Canfigurabon Running contiguration wil 5e lost unies:

Save Current Canfiguration o PC

Save the configuration displayed above to your PC.

sons 4 mpremes Save As...

s saved to start up configuration.
Teinat

Raload Device

- Evien

Ralee | | oyt |

12
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21. Navigate to “Configure”>"Unified Communications”>"Advanced
Telephony Settings" to configure the Web admin settings.

a. Select the “System Config" tab.

b. Enter the administrator’'s username in the “System
Username” field.

. Enter the password in the “System password" field.

d. Leave other fields as default and then click the “Apply" button.
———— ﬁ S 3 s 3

% ‘:t “ e Cisco Configuration Professional pt

Configure » Unified Communications > Advanced Telephony Settings

Message dizplayed on phone:
Diractory naming schema
¥ £3 Unified Communications Music on hold:
| unhad Cer
| Telephany Settings
T ,

Bhone default BIN:

Web ademin settings

o s Configure system and customer web administratar sccount.

» G Trunks
> 54 Dis! Plans System pazzword *
» L4 Telephony Featuras
Madia
Unified Communications Sacurty Audit

System usermame 1

[ Ensbie customer wab account

Customer usermame:

Customer passmord

¥ Flash Fle Managament

£ Conbiguraion Edtor

" Sava Canfigurstion ta PC

£ wnte to Stanup Canfiguration
& Tainat

P reond bevien

»Qven

22. Click the “Deliver" button.

wlnale
cisco

Cisco Ci ation Prof

Folloming commands wil be appied to the device s running confgurstion

telephony-servi e
b admin system name sdmin secret 0 *TTEE
ex

Running configurabion will be lost unless it is saved to start up configuration.

Save Current Configuration to PC
Save the configuration displayed above to yaur PC.

| Save As...

13
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23. Navigate to “Configure”>"Unified Communications”>" Users, Phones
and Extensions'>"Extensions” to create extensions for routing inbound
calls from the SIP trunk.

a. Select the “General" tab to create a new extension.
b. Enter a new extension in the “Primary number" field.

c. Enter a DID assigned for routing inbound calls to this extension in
the “Secondary number" field.

d. Enter a descriptive name for displaying on the IP phone in the
“Name to be displayed on phone line" field.

e. Enter a description in the “Description” field.

f. Select “Do not register any number” in the “E.164
registration” field.

g. Leave other fields as default and then click the “OK" button.

Apphcation  Help

(5} Hewme configure | ) Monitor W e (& Cisco Configuration Professional lali
- = cisco
i el ®  Configure > Unified Communications > Lsars, Phones and Extensions > Extensions 2
Gukied Configuration »
m Primary Mumbes | Label user Line Mode
- [ — o
Tele etting: General  Advanced
” Primery nemint * 303
!

Socondary number: 6316769582

Hame ¢ be disclayed an chone ne: [6316769582x303

Description CME extansion 303

B Rpu—— ket yuinony s j x| S Vg

|| Block eslier I for calls from this extension

24. Click the “Deliver" button.
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& - Cisco Configuration Professional '_
g 5CO

description CME extension 303
it

ning configurstion vill be lost unless it i saved to start up configuration

Save Current Configuration to PC
Save the configuration displayed above to yeur BC

|_saves... |

Delwer | Cancel |

25. Navigate to “Configure”>"Unified Communications'>"Users, Phones
and Extensions'>"Phones" to add IP phones.

a. Click the “Add" button and from the “Setup a new phone" screen:

b. Select “7962" from the drop-down list of the “Type of
phone" field.

c. Enter the IP phone's MAC address in the “MAC address" field.
d. Leave other fields as default and then click the “OK" button.

_ P - |

Mpplication  Help

v
\ | ) tome | Lt w (4] Cisco C ation Pr i il

cisco |
% Balect Community Member d
«

aaanans v] Configure > Unified Comm

e 5 Uners, Bhones and Extansions 3 Phonss 2

Bhone Type User Brimary Extension

ot e C—
MAC address *: ECCBS82112F43

Router's part phone is connected to:

Auto-tine selection: Enable v |
LI enable videa support

Night Service

Night service feature farmards incoming calls from unstaffed

|| Aliow this phone to make blocked calls during after hours

__| Enable Remote Worker

Remaote worker tonfiguration allows 5 phones or mstances of
Cisco 1P Communicater from ramote office/ home to connect
t2 8 Ciace Unified CME system over 3 WAN. The maximum
number of remate phones that can be supparted iz
datermined by the avaiiable bandwidth,

Select codec type.

» G vien Mete: Codec G.72918(8 Kbes) requiras transceding suppert

e LR ——

L) LSt ) &

26. Click the "OK" button.




-

s ot configurad for this phone type
e may ot operate oropery

Configure the phone firmware from Shone
Firmware seresn

[ o< |

27. Click the “Deliver" button.
T

B oo Cisco Configuration Professional

Jw

7062 .

Fellowing commands wil be apphed o the device's ru

ning configuration
ephore 3

| mae-sddress eccs.sat1.2raz
type 7962
sute-iine

| exit

Bunring configuration wil be lost unless i it saved to start up configuration
Save Current Configuration ta PC

Save the configuration displayed above to your PC.

| save As...

| Deliver Cancel

Navigate to “Configure'>"Unified Communications'>"Users, Phones and
Extensions">"User Settings” to assign IP phones and extensions to users.

a. Click the "“Create"” button and select the “User" tab from the
“Create User" screen.

b. Enter a user ID in the “User ID" field.
c. Leave other fields as default and then click the “OK" button.
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© Cisco Configuration Professional il
cisco J
g i Pl S 5 Unar Fattings ;ﬂ-,'
O roves retrieved Guided Conbguration »
PO P [V e —"—— - it
i : Name Name ame s Type Address

User  Phone / Extensions il

user 1D cmEs0n
First Narme:

Last Name:

Display Name:

Launch Wizard...

Pazznerd Ganaranon: | Use Blank Password -
New Password:
Cenfirm Password.

BIN Gereration:

| Use Blank PIN -

New BIM: (4-8 digits)

Cenfirm PIN: (4-8 digits)
| ok || cancel

Creats...

=

Select the “Phone/Extensions” tab.

a

. Assign the phone to the user by selecting the MAC address of the IP

phone from the drop-down list of the “Phone” field.

b. Select 1" from the drop-down list of the “Phone Line" field.
¢. Assign the extension to the user by selecting the extension from the

“Available Extensions’ box and then click the “>" button.

. Leave other fields as default and then click the “OK" button.

Application  Help
L) e B ronitor % e £}  Cisco Configuration Professional aliali
. A cisco "!
Select nity Member 4 I
100104 |« “  Configure > Unified Communications > Users, Phenes and Extensions > User Settings '
., [ —
' [P — %
Errors detected in Phone / Extensions tab,
Comect the areas hi bedow (s the hi fields to see details):
User | Phone / Extensions | 1ol
Phone ECCH.8211.30EF(7962) | v
Phone Line |1 -
Line Type: Reguiar .
Ring Behavier: | mormal =
fcnrnx LI, ;-
Extensions
Show All -
Available Extensions: Selected Extensions:  line & | Extension | Line/Ring Type
e~ NS i 301 Regular/Normal
303 i,
< 3
:
€ 2
B
Croste ] * intestes & mananion fais
- ... ')

B e e e
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30. Click the “No" button.

.
A

y Cisco Configuration Professional L 8
cisce
- . ‘
wanias v L S S S —— 3
oot ¢ mtgmratis .
User  Phone | Extensions.
Phane % | Ecca.s211.2743(7062)  »
Phonene |1 =
Line Type:
Ring Bahavior
P [T—
Line #  Exteasion  Lina/Ring Type
301 (CME301) " Reguiar/Normal
——
o
Create
-]

31

=S .

Click the “Deliver" button.

Application  Heip

Wome pr— [ p— e &
- =

Cisco Configuration Professional bl
cisco

[20a0105 |« " i y.

Last Display  Extmnwion Phone  MAT
Mame  Wame Hame & Tyne Address ok L P,

User  Phone / Extensions

i Phoms = eccasat1.araaee) —
oo o (i3 5 .
; ! ez Line Type: Regular - =
: P~ -

Follomng commands wil be applied to the device's running configuration.

ephone 3
usemame CME301
cuires button 1:1

ext
ephone-dn 1

name **
et

« ] Funning configuration will be last unless it is saved ta start up eonfiguration.
g Save Current Configuration to PC
e Save the configuration displayed above to your BC.
|

Save As...

Cranta.
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32. Navigate to “Configure”>"Unified Communications'>"VolP Settings"
and then click the “Edit" button to configure the VolP parameters.
a. Select the “General VolP Settings" tab, check the checkbox for
“Allow SIP to SIP connection”, leave the other fields as default and

In rder to connect two dzparate VaIP networks, the Sevice must be confgurad to allow different tyses
of andpoints to communicate. Selact from one of the foliowng options.

V] e 559 10 51 connazton
L] llow 518 to #.323 conmecbon
v L] Allow K323 to §18 connection

(] Allow H.323 to H.323 connection

33. Click the “Deliver" button.

General VoIP Settings  SIP Settings  H.323 Settings.

In order to connect two disparate VoIP networks. the device must be configured to aflow different types

of andpaints ta communicats. Selact fram one of the followng cations.
(] Atow 519 to SIP connection

|| Allew 519 ts H.323 esnnestion
|| Atlow #,323 1o SIP connection

L] ARow H.323 to H.323 connection

Following commands vl be applied to the device's running configuration

vaice service voip
exit

w—
F Running configuration wil be lost unless it is saved to start up configuration.
Save Current Configuration to PC
R
Save As...
40 () (oot )

| ex Cancel |
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34. Select the “SIP Settings" tab, check the checkbox for “Use SIP 302
moved temporarily for call forwarding”, uncheck the checkbox for “Use
SIP Refer for call transfer”, leave the other fields as default and then
click the "OK" button.

| b L Interface Managemant
| b L Routar
¥ (3 Secunty

| v B3 Unitied Comma

| Queitesc P

L) Telephony Ssttings

vs|
Ly Advanced Telsphony Setbngs

52§ Users. Phones and Extansions
Jveis Suttings

» G Trurks o

» () Diai Plans
» (@ Telenhony Features

L) Media Re:

L Unified Carm

If the peer VelP davice supperts SIP Rediract and Rafer mazzages, then thiz davice can ba anablad b
use SIP Redirect messages for call foruarding and $19 Refer messages for call vansfer. 1f this
functionaiity is not ansbled on this device, then calls hairpm through the device.

V] Use SIF 3062 moved temporarily for call formarding

L] use SI® Refer for eall transter

The SIP registrar accapts SIP Register messages from lacal SIP phones.

| Enable local ST ragistrar

il

Cisco Configuration Professional
- = cisca

then this device can be enabled to
sl transfer. 1f this

wpports SIP Redirect and Refer
or call forwarding and SIP Fefe
x davie iz hatro

302 moved temparanty for call forvarding

|| Use SIR Rater for cal transter

The SIE registrar accepts 517 Register messages from local 51 phones.

|| Enable locs] SIP ragistrar

Feliowng cammands wil ba 3pphed 16 the device's runming configuratian.

voice sennce vorp
he supplementary service sip rafer
wat

Running configurstion will be lost unless i is saved to start up configuration.
Save Current Configuration to BT
Save the configuration dispiayed abov ta your PC.

Save As...

20



Vil

36. Select the “H.323 Settings" tab,

a. check the checkboxes for “Use H.450.2 protocol for call transfer”,

“Use H.450.3 protocol for call forwarding” and “Use H.450.7
protocol for call MWI"
b. leave other fields as default and then click the “OK" button.

[ oo || o | | 2 O 2 0 Cisco Configuration Professional ‘é""'ﬁ".

1F the peer VoI device supports W 450.2 and H.450.3, than this device can be configured to use H.430.2
for call transfer and H.430.3 for call forwarding. If this functionality is not enabled on this device. then
calls hairpin thiough the device.

Uit &
= ¥ use H.430.2 protacel fer call ransfer
] Talaphany Settings

v s
\‘ L) Advanced Telaphony Settings S My Sestonat o 0 Pl
» £ Users. Phanes and Exsensions
When H450.12 is snabled, the devics automabically detects when an H.450.2 iransfer or M.450.3 fomard
15 possibls wihin the VoIS network. When this isn't possibls, the device falls back 1o using Vel® hawsin
routing.
v

|| Use H.450.12 protocol for discovering call transfer and call forwaeding capabilities

I The Message Waiting Indication [MWE) feature notifies uzers about vaiting voicemail messages.

[¥] Uss H.430.7 protasel for Mwi

o Managamant
# Configuraton Edior

# save Cantiguistion to 6T
“winte to Starup Configuration
FTeimer
,*Reload Deviee

» Eyvian

* lrasares & mavaaren w4

Hame B e e e L3 Cisco Configuration Professional ‘éllllizléh !

Genersl VoIP Settings  SIP Settings  M.113 Settings

5 o N e it D 1 o AR, i i et o AL
aso. 1 this funchonabty @ not enabled on this den

) wse 1.430.2 protacel for cat wansar

) use 4430, protaco for cat forearding

Jonie cemems Whan H.430.12 is enabled, the device automatically detects when an H,450.2 transfar o+ H.430.3 forward
1z sazmbla wehin tha VEIP natweric. Whan thiz mn't poznsie. the device fals Back ts using ValP haimn
routing.

L use Han

The Message wanll|  Following commands i be apeked to the device's runing configuration.
) o nasll [ emrce o

i
v Running canfiguration wil be lost ualess ¢ is saved to start up configuration.
. Save Corrent Configuration to BC
o Save the configuration disslayed above to your T,

“ @

o
- Ltemde )
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38. Navigate to “Configure”>"Unified Communications”>"Trunks">"SIP
Trunks" to configure Optimum Business SIP Trunk Adaptor as the SIP
service provider.

a.

Click the “Edit" button, select “-- Generic --" from the drop-down
list of the “SIP Service Provider" field and select the
“General" tab.

. Enter the “Primary Server" IP address. This is the IP address that

was assigned to the Optimum SIP Trunk Adaptor’'s LAN interface.
This address was configured in Step 2 in the Optimum Business SIP
Trunk Set-Up Guide.

. Enter the “Registrar” IP Address if you are configuring the PBX for

SIP registration mode. This is the IP address that was assigned

to the Optimum SIP Trunk Adaptor’s LAN interface. This address
was configured in Step 2 in the Optimum Business SIP Trunk Set-Up
Guide. Leave this field blank if you are configuring the PBX for
static IP mode.

. Enter the “Outbound Proxy" IP address. This is the IP address that

was assigned to the Optimum SIP Trunk Adaptor’s LAN interface.
This address was configured in Step 2 in the Optimum Business SIP
Trunk Set-Up Guide.

. Enter the PBX's GE 0/0 port's IP address in the “SIP Domain

Name" field.

f. Enter a valid DNS IP address in the “DNS Service Address"” field.
g. Enter the maximum number of concurrent calls allowed in the

“Maximum Number of Calls Allowed" field.

h. Click the “OK" button.

" nrtp//127 0.0 18600/ Counterpoint/CPMan himifrand=3 1404 - Windows intermet Explorer - o 5

=

39.

B ronno Cisco Configuration Professional

SIP Service Provider : - Goneric —

Domain Name Service Settings

Click the “Deliver" button.
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e

Cisco Configuration Professional

Running configurabion wil be lost uniess 1 is seved to start up configuration

Save Current Configuration to PC
Sava the configuration displayed above te your BC.

Save As.. |

| Delwer || Concel |

Note: This step is needed only if you are configuring the PBX for SIP
registration mode.

40. Click the “Edit" button, select “-- Generic -" from the drop-down list of
the “SIP Service Provider" field and select the “Authentication” tab.

a. Click the “Add" button to set up the PBX to send SIP registration for
the pilot DID. Note that the username and password must match
what has been configured on the Optimum SIP Trunk Adaptor. This
is step 3 in the Optimum Business Sip Trunk Set-Up Guide.

. Enter the username in the “Username" field.

. Enter the password in the “Password" field.
. Enter the realm (if needed) in the “Realm"” field.
. Click the “OK" button.

® O O T

=

i ; i i il
Cisco Configuration Professional c1ce

y

i
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41. Click the “Deliver" button.

4 hipd/127.00; = 31404 - Window; Internet Explorer

Dt Cancel

42. Navigate to “Configure”>"View'>"Running Configuration” to see if the
DHCP server on GE 0/1 interface (IP address of 192.168.0.1/24 in this
example) is set up to send “option 150" (TFTP server IP address) to the
DHCP clients when the IP phones are restarted. If “option 150" is not in
the “ip dhcp pool ccp-pooll” section, the IP phones would not be able to
retrieve the files created for the IP phones by the PBX. To take care of
this problem, enter the following CLI commands from the console:

cisco2901cme#configure terminal

Enter configuration commands, one per line. End with CNTL/Z.
cisco2901cme(config)$ip dhcp pool ccp-pooll
cisco2901cme(dhcp-config)#option 150 ip 192.168.0.1
cisco2901cme(dhcp-config)#exit

cisco2901cme(config)#exit

cisco2901cme#
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) Advanced Telephony Settings
* [y Users, Phenes and Extensians
LA vetP settings
By Trunks
L3 SIP Trunkes
(24 Disl Plans.
* 3 Telephany Features
Ly Med. rcos

munications Security Audi

e p————
o

) etond Devics

¥ Elvien

47108 Shom Commands
[ Detauit Rules

Cisco Configuration Professional 'é"
Utilities > View > Running Conhguration

Resubts of show running-canfis
Buiding configurstion.

Current configuration : 7264 bytes
* Last configuration change st 21:17148 UTC Mon Jan 10 2013 by admin

version 15.4

no service password-encryptien
hostname csco2301cme.
boot-stan-marker

800t systam flash:c2900-univarsalks-mz.SPA.151-3.T.6in
boot-end-marker

logging buffered 31200 warings
no logaing

o ass revemodel

ip dhcp exchuded-address 192.168.0.1 192 168.0.5
ip dhcp excluded-address 197.166.0.51 152.168.0.254

ip 8hep pool cep-posi1
92.168.0.0 255.255.255.0

defauk-router 132.168.0.1
opbion 150 ip 192.168.0.1

43. Navigate to “Configure”>"Unified Communications”>"Dial Plans'>
"Codec Profiles" to group “g711alaw" and “g71lulaw"” into the same

codec class.

a. Click the “Create” button and from the “Create Voice Class

Codec" screen:
b. Enter “1" in the "“Voice Class Codec Number" field.

c. Select the "“g711alaw" codec from the “Available Codecs" list and
then click the “>" button.

d. Select the “g711lulaw” codec from the “Available Codecs" list and
then click the *“>" button.

e. Click the “OK" button.

Configure > Unified Communications > Dial Plans > Codec Profiles

o lowest priority order.

» [ users. Phonss and Extensions

|
[y vol® Sattings
¥ By Tunks Voice Class Codac Number *: I:l (4 - 10000)
_18IP Tranks
v Byl Plans | e
e I Aveiiable Coducs + Asssistend Codie (Hightst to Loast Brisity) 1
Qiverr e =] (2 | [arsreien =
| Teanslation Rules and Profiles claar-channel B £ |g7trolan ~
[ Calling Rastrctans 072248
i e |3 ]
- prmrm—— e I=] (] x
_ 3 miter Hour Tollbar 12
S = * rdratme o eram— f—
*Flash File MEnagement ox Cancel
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44, Click the “Deliver" button.
o 18600/ 31404 - Windows Intemet Explorer P - ‘.h_e\:ﬁ

45. Navigate to “Configure'>"View">"Running Configuration” to see if
EdgeMarc's IP address is in the “ip address trusted list” under the “voice
service voip" section. If it is not there, inbound SIP calls from EdgeMarc
will be rejected by the PBX with a SIP “403/Forbidden” response. To take
care of this problem, enter the following CLI commands from the console:

cisco2901cmettconfigure terminal

Enter configuration commands, one per line. End with CNTL/Z.
cisco2901cme(config)#voice service voip
cisco2901cme(conf-voi-serv)#ip address trusted list
cisco2901cme(cfg-iptrust-list)#ipv4 10.10.10.2
cisco2901cme(cfg-iptrust-list)#exit
cisco2901cme(conf-voi-serv)#exit

cisco2901cme(config)#exit

Cisco2901cmett
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“ utilities > View > Running Configuration

Resuits of show running-tanfig

¥ £ Intarface Managament
] Imterface and C
) Energywise |
» @3 Router !
ervpto pii certficate chain TP-self-signed-1453359325
» 4 Secunty certificate self-signed 01
30820228 30820194 AQ030201 02020101 30000605 24864886 FT0DOL0L 04050030
31312F30 200603255 04031326 454F5320 53656066 2D536567 6E65642D 43657274

enrliment selfsigned

revocation-check none

¥ E3Unfiad Communicatians

) Unified Communications Fea 69666963 61746520 31343933 33353933 3235301€ 17003131 30313036 32333028
32365417 DD323030 31303130 30303030 305A3031 312F302D DE035504 03132649

[ Telephony Settings 4F332053 636CEE2D SIES67EE 65642043 6727465 E6E36361 74652031 34393333
[ Advanced Talwphony Settings 35393332 3530819F 30000609 2A864886 F70D0101 01050003 81800030 81890261
o ‘81008155 CEE4BEAL 5807021 ECEBICHE 0IVEECF1 55754ABD 39258A51 26ADISAF

» 4 Users. Phones and Extensior 871EC284 305F3F1B IOBODEE S681E4CS SASSESS2 03424CCF 1081109C ECI1262

L) verP Settings " 71125180 D2104578 SADS739F DEB1SE27 24440208 FI2C4FED €1CFCCD) GSAZFEDE
1109E570 DF7TF4A2 AL1C1086 726467 1A 2ABI2A93 EFADCEST EADE29EA D24B40ES
v By Truns F0810203 01000143 53305130 OF0603SS 10130101 FFO40530 030101FF 301F0603

551D2304 18301680 14016241 95206817 D141FT2F AD91BBFD SB81DC0S D7301D06

Lysie Trunke I | oass100E ps160814 01624195 206E1701 43F72FAD 91 8EFDSE B3DCISDT 300DOsTS

¥ E90ial Plans. 2ABE4886 F70D0101 04050003 £181006F 310E1E88 SDCB43F0 EB1D7EFE SALDA4ST
51574804 E7AACIEC 9541767 23067108 26BCAS7E D7BES19F 1A9A1F1A SB7CB3ISE

Brors 35085597 03038644 CII2FEEE AT443042 EOBI1FAD BASBETEF FOS4EIS 73726136

Ly verp 7290FS62 42EBB22E 383FOSCA B179BE4A ED4CLEZE SEISLFES D177DBAA FEAAS2EL

82390854 TDSFFERS DIETERSZ £10944
[ Translation Rules and ro po
|y Calling Restricticns i
) Codes Profiles |
'
» (3 Telaphony Features O
ip address trusted hist
ipv4 10.10.10.2
sliow-connectons sip to sip
o supplementary-sarvice sip refar
fax protocol 138 warsion 0 ls-redundancy O hs-redundancy © fallback none

se
‘sutbound-proxy ipv4:10.10.10,2

'

veice elass coder 1

codec prefarence 1 g711alaw

/108 Show Commands. codec prefarence 2 g711ulaw

Default Rules

46. Navigate to “Configure”>"Unified Communications'>"Dial Plans'>"VolP"
to complete SIP trunk configuration for Dial Peer. Note that the first Dial
Peer entry was automatically created for incoming calls by the PBX when
SIP trunk was configured.

) . - "
<t ¥ ) cisco Configuration Pr 'él;"
> VeIp
| 1 rovs retrimvad |

¥ €5 Interface Management =4 o = i Numbers. lnu-.u...s Brofile Brofile

|} Interface and Connections | Outgeing  Incoming

| 1 === Incoming ¢ T sio-server

[ Energywise .
» i Router
» (5 Security

v E2 Unified Communications
] Unified Communications Fea
[ Telephony Settings

) Advanced Telephony Setting:
# L Users, Phones and Extensior L
) VeIP Sattings

v B3 Trunks
[ 51P Trunkes (]
¥ E3Dial Plans
[aroTs

L) Transiation Rules and Pra
L) Calling Rastrictions
] Cadec profiles

» 2 Talephany Features
_]Media Resaurces.

/" 8ave Configuration to PC
o Write to Startup Configuration
o Telnet

/*Raload Device

>R view

Fan Dulete

Vil
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47. Select the Dial Peer number 1 entry, click the “Edit" button and then
select the “General” tab to change some parameters and leave Dial Peer
Number 1 for incoming calls only.

a. Select “g71lulaw" from the drop-down list of the “Codec"” field for
now as selection for “Voice Class Codec" is not yet available.

b. Select “rtp-nte” from the drop-down list of the “DTMF Relay Type"
field. This allows the PBX to relay outbound DTMF with RFC-2833
DTMF. Note that, for inbound DTMF, the PBX will recognize
RFC-2833 DTMF only.

c. Leave other fields as default and then click the “OK" button.

e o B B A |

Application  Halp

contigure. || [} onsor e €a ) Cisco Configuration Professional ']+
[ Vi o = 'gu " ' c15¢o

[a0an101 \ - | Configure > Unified Commussications > Disl Plass > ValP 3

Description *** Incoming call to - — Generic -- - SIP Trunk **¢ = (1-64 Characters)
Brionity | Prionty 0 -
Remots Site ¢ Q &) SIP Trunk

Destination Humber
Incaming Called Numbar £

Anzwer Address

Shutdown Disl Peer o ve (O ves
e o s
Codec. = | a71ulaw | ® ] (U vese Class Codec
DTMF Relay Tyse p-nte |-
it
Voice Activity Detection
v With vaice Actvity Detaction enabied. only spesch voice data Backets are sent sver the netwark, and sience
o e b ek e oo bt
= (W] Enable voice Actuity Detactor

~sTe— |

48. Click the “Deliver" button.
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Hama || o contigurs | (} monstor @ J Cisco Configuration Professional ' Jiths
J - cisce
[amana0d |= #  Configure > Unifled Communications > Dial Plans > Vo1
eal Poar 71 EMRMELES Dial Besr L
General | Digit Mamipulation  Calling Restrictions
Dial Pear Number
Descripton +7% Incoming call to - - Generic — - 5IP Trunk | (3-64 Characers)
Prory | Priority 0 -
famote Site o 818 Trunk
Destination hu -
incoming Caile
Answer Address J]|  Following commands wil b applied to e device's amning condigurstion.
Shutdown Duai of [ disl-pesr voice 1 voip
o shutdown
dtmi-relay rtp-nte.
preterance 0
Protocol codec g71 lulaw
ot
Codec
oTME maimy Tyd
Voice Activit]
Sl With voice Ag
voie dats pal
o Enable Vol Running configuraiion il ba loat uniass & i ssvad o start up configuration.
Save Carvant Canfiguration ta PC
Save the configuration dsplayed above to your BC.
i - Creste.. 4 . Save As..
N 4 ————
LS ) | Satedl-

49. Select the Dial Peer number 1 entry

a. click the “Edit" button and then select the “General” tab again
to choose the Voice Class Codec that includes both “g71lulaw"”
and “g711alaw".

b. Select the radio button for the “Voice Class Codec”.

c. Select “1" from the drop-down list of the “Voice Class Codec" field
and then click the “OK" button.

Cisco Configuration Professional *!1t:411s
1sco Configuration Professional < ?

=%+ Incoming call to - - Genene -~ - 5P Trank *+*  (1-64 Charactars)

Q (&) 519 Trunk

Destination bumber -
Incoming Called Numier T
Arsvar Addresz

Shutdomn Disl Peer ) o

Voica Class Codec | 1 -

wiith Veice Actvity Detection anabied, only speech veice data packets ars sant svar the netwsrk, and sience
voice data packets are dropped opemcEng the network bandwdth uzage

] Enasie vors Accvy Gatasten

s ooemd |




50. Click the “Deliver" button.
P 3048 e i L pea W=

51. Navigate to “Configure'>"Unified Communications”>"Dial Plans">"VolP"
to create a second Dial Peer for SIP trunk for outgoing calls only.

a. Click the “Create” button and then select the “General” tab.

b. Enter a description in the “Description” field.

c. Enter "9T" (9 followed any numbers) in the "Destination
Number" field.

d. Select the radio button for “Voice Class Codec" for the
“Codec" field.

e. Select 1" from the drop-down list of the “Voice Class Codec" field.
f. Select “rtp-nte” from the drop-down list of the “DTMF Relay Type"
field. This allows the PBX to relay outbound DTMF with RFC-2833
DTMF. Note that, for inbound DTMF, the PBX will recognize

RFC-2833 DTMF only.
g. Leave other fields as default and then click the “OK" button.
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(1] Cisco Configuration Professional *!I!
..
e o Configure > Unified Communications > Dial Plans > Vol
1 i =
¥ ) Irnterface Mansgament - Disl Peer Tag Description

L tntartaca and Cannecons

General  Diait Manipuiation  Calling Restrictions

Dial Pear Number *: i
¥ 3 Unifled Communicatiors

e [k | 80 e
e

o e e

R i

Remote Sie : Q (& SIP Trumk
53 Unncs, Bones and Txtansions |
[ vorP sattiogs : -
» B3 Trustes
|51 Trunis | Incaming Called Humbe: -
¥ Byl tinns Anaver Addrass ¢
Lyeors vt Biot Best's ———
L) Transistion Rules and Brofiles
rosscal + o ae
[yCalting Rastrictions
| ced: Frofins cadaz ¢ O | erasa = | () Voice Class Codec | 1 -
Ly Telephany Foatires DTHE Ratay Type ¢ it
L Madkn Resources =
3 Vorce Actnaty Detection

With Vesce Activity Detaction enabled. anly speech voice dala packets are sent aver the
T ——r— g e

i #nd silence vowce data packats are dropped optmizing the
# Save Configuration to BC J SR

F Weite to Stastus Cantiguration
W Talne

o Retusd Device

e 4 =g, Saie

W & € Cisco Configuration Professional

Cantigurs > Unifiad Communication > sl Plams > VTR

4 vorm et

- Dinl Pea Number * 2
o esengtion ¢ [Gugoing ool = 81 bumk | (354 Characters)
Triapnany Setumgs Priority Priority 0 -
&
VR L B S T (T N
<
e s
Y s
descristion Cutgoing <all to SIP trunk
ek
[ Coiling B et Frong zeszien target e server
) Coociae eails Coddll | dirntreiay rip-wis
i e o 8
- r oTme -d
! =
.
"
F % Running conhigu saved to stan up contigy
ci |
‘Save Current Configuration to PC.
i i Al skl
EEC Create., chimalll | LAmte: |
=
: |_petwer | |_comee_|
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53. Navigate to “Configure”>"Unified Communications”>"Dial
Plans'>"Translation Rules and Profiles" to create an outbound rule for
removing SIP trunk access code before dialing.

a. Select the “Translation Rules" tab and click the “Create" button.

b. Enter “1" in the “Translation Rule Number" field.

c. Click the “Add Rule" button.

d. Enter “/~9\(.*\)/" in the “Match Pattern” field to match a string of
numbers starting with a “9".

e. Enter “/\1/" in the “Replace Pattern” field to replace the matched
numbers with the same numbers without the leading “9" digit.

f. Click the "OK" button.

Fﬁiﬂﬂ Pint/CPMain.hir Trand = 31404 - Window: Internet Explorer
Mgt aiy

PR [
3 T -~ ot cisco

- contigmrs | [l wemae e &3 Cisco Confi ation Prof

54. Click the “Deliver" button.
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120000 et it evonsere oo ST s

i Cisco Configuration Professional
14:]

Running configuration wil be lost unless it is saved to start up configuranon,
Save Current Configuration ta PC
Sava the configuration displeyed sbove to your BC.

Save As...

55. Navigate to "“Configure'>"Unified Communications">"Dial

Plans">"Translation Rules and Profiles"” to create a Translation Profile to
hold the Translation Rule for the called number.

a. Select the “Translation Profiles” tab and click the “Create” button.
b. Enter a descriptive name in the “Translation Profile Name" field.
c. Select “1" (Translation Rule #1) in the “Called number Rule" field.
d. Leave other fields as default and then click the “OK" button.

T —

el
Apphcation Help
) woma [ 17 contigure | ) womsor N 6 L0 Cisco Configuration Professional *!|111]1s
= L ¥ cisco
= ®  Conigure > Unified Commmunications 3 Dis! Plans > Translation Rules asd Broflies 3

Transiation Rules  Translation Profiles

Transtation Brofile  Called Number Rule  Calling Number Rule  Redirect Called Redirect Target
Name Number Rule Humber Rule

Translaten Brotile fame 0 SIP_Trunk_Rules (1 31 charactars)

Called number fule: G

Calling number Rule:
Rediract Called number Rule:
Redirect transter-to/forvard-final Number Rule: | Nome

Create...

56. Click the “Deliver" button.
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Auplication Meln
Y ome contigure | [} Manttar w e L Cisco Configuration Professional |11 111
o . cisco
e e——r—
[teasa0s [=] ®  Configure > Unified Communications > Dial Plans > franslation Kules and Brofiles P
TresslstionRuiss | Tranaletion Profies
Tramsintion Brofie | Cabled Mmibarfisle | Colling tumnbe Bl ndiwact Called pr—
wame Number Rule Mumber Rule
Followng commands wil be applhed to the device's running configuration.
=l voice transiation-profile SIP_Trunk_Rules
translate called 1
it
Webbing seniipiseiies il b bosk wolus 1 moved 4o siodt ) oarllgunion:
e Save Currant Configuration to PC
ok ‘Save the configuration displaved above to your PC.
[y
: . Create...
inet - Deliver Cancel
i |

57. Navigate to “Configure'>"Unified Communications">"Dial
Plans">"Translation Rules and Profiles” to create outbound rules for
configuring caller ID.

T ———

v B9 Intarface Managamant
L 1nterface and Connactions
A eneraywise
» 3 Router Match Pattern: /“$\(*\)/ Replace Pattern: /\1/
» (5 Security
¥ E3 Unified Communications
) Unifiad Communications Faaturas
) Telaphony Settings
) Advanced Telaphony Settings
» (3 Users, Phones and Extensians
] VeIP Settings
v B3 Trunks
L] SP Trunks
¥ £3 0ial Plans
Lypors
Ly vare
®

] Calling Reatrictions

& Conhguration Editor

o Save Canfiguration ts PC
7 Write to Startup Configuration
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. Select the “Translation Rules" tab and click the “Create" button.
. Enter “2" in the “Translation Rule Number" field.
. Click the “Add Rule" button.

. Enter “/~30[1-31/" in the “Match Pattern” field to match all the
extensions starting with a “3", “301", “302" and “303".

e. Enter “/6316769580/" in the “Replace Pattern” field to replace
each extension with the pilot DID. Note that this example is for
SIP registration mode where only the pilot DID can be used as the
caller ID. For static IP mode where each extension may use its
assigned DID as the caller ID, different translation rules will be
needed for mapping all the extensions with different caller ID.

For example, to map extension “303" with caller ID of
"6316769582", set the “Match Pattern” to “/~303/" and set the
“Replace Pattern” to “/6316769582/".

f. Click the "OK" button.

o 0O T w

& - Windows imemet Explorer REEwTRL> | o
L Cisco Configuration Professional -
co
Create Transiation Rule FE 3
" S rr— T
Match Pattern Replace Pattes -
130f3-3) /6316768580¢
Add Rule
Delete Rule
o Concel

58. Click the “Deliver" button.



Transiation Rules

Craate..

Q- : —

Configure > Unifiod Communications > Dial Plans > Transiation Rubes snd Prafiles

Transistion Rule Number Rules

. Save As...

Cisco Configuration Professional ke
cisco

Transiation Draviles

Transtation Rule Nurmber = (Mumbers 3-2147483647)

Note: To re-order rules. drag and drop the rule in the tabie
Match Pattern Replace Pattern

/63167685807

/~3001-3)/

Falloving commands wil be applied to the device's running configuration.

voice translation-rule 2
rule 1/730{1-3)/ /6316769580(
ot

Running cenfiguration wil be lost unless & is saved to start up configuration.
Save Current Configuration to BT

Save the configuration displayed sbove to your BC.

) e )

59. Navigate to "“Configure'>"Unified Communications'>"Dial
Plans'>"Translation Rules and Profiles" and select the “Translation
Profiles” tab to add Translation Rule #2 for the calling number to the

Cisco Configuration Professional 'é'""

¥ £y Interface Management
| Interface and Connections: |

| 1 rovs ratriaved |

[ Energywise proxemy
» 3 Routar S18_Trunk_Rules
» L Security
¥ E3unified Communications.
] Unified Communications Features
| Telephony Settings
jAdvanced Telephony Settings
» G Users, Phones and Extensions
[ VoIP Settings
v 3 Trunies
1 510 Trunks I
¥ E30ial Plana
Qrots
Jvete
| Calling Restrictions
] Codec Prafiies:
» L Teleahony Features
] Media Resources

*Configuratien Edrtar
P*Seve Configuestion to BC
/Wit to Starkan Canfiguration
P Teinet
*Reload Device

i Redirect Target
Number Rule

Delete

Create... Edi

Vil
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a. Select the Translation Profile and then click the “Edit" button.

v B9 Interface Managemant
1) Intertnce and Connactions

| & rows ratneved |

[ Eneraywise
i Router

L) Unified Cammunications Fetres
) Telephony Sestings
L) advancsd Talephony Satonos |
* Qi Usera. Phones and Extensians |
(] volP Settings
T B Trunks Transiation Profile Name *: SIP_Trunk_Rules
(S1P Teunks \ —
v Ly oial Plans
Lyvors

Lyvere

Called number Rule:
Calling number Rule:

Redirect Calied number Rule:

Redirect transfer-to/formard-final Number Rule:

[y Caliing Resmiesans
* irdiates @ mardatay beed
) Codec Profiles

» Ca Twiaphany Famturez

|| Medix Resources

_* Configuration Editor

¥ save Configuration 1o PC

7 Write to Startup Conbguration
P Tinst
P Relond Devica

K" button.

k31404 - Winddows Internet Explorer

&0 Cisco Configuration Professional ';""'

> Dial Plans > Translation Rules and Profiles.

w £ intarface Management

) tnterface and Connactians
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e e
|+ Security

¥ B Unified Communications

) Unifred Communications Features
) Teleshony Settings
) Advanced Telephony Settings

# & Users, Phanes and Extensions
|jVelP seings

D Trunks Transistion Brofile Name *:

SR ik I Called number Rule:
¥ ol Plans

@ o Calling number Rule:

Redicact Called number Rule:

R e ]

1 Sains ponbiniaibrest-Benl manber nilsr (s i

[ Codec Prafiles
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. Configuration Editor
7 Save Configuration te BC
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60. Click the “Deliver" button.

TR e W W .

Applcatan  Heln

L vers || SEiconems || g wwone: w e L Cisco Configuration Professional *'1t1l
|

cisco
[1oasana [+] % Coniigurn > Urkisl Garmmanications > Tl Mans: > Translation Rulas aed Srabies e |
Iranslation Kules  Transiatien Pratiles
Toonetutive Brsfils | Colled Wamiis Mals | Caltng Munbes fide. | Modiict Called Nsiior, Nadivact Yasgst
[ ke b Hule
.
S Tmmihdes (1~ 31 chesacters)

el Calling number Rule: (A=

Fallomng commands wil be spplied to the device's running configuraben.

voice transistion-profle S1P_Trunk_Rules
translate calling 2
exit

.
Running configuration wil be lost unless it is saved to start up configuration
Save Current Configuration to BC
Save the configursbien displayed sbove to your PG,
Craste. e
- Save As...
o

et ] | Gl |

61. Navigate to “Configure'>"Unified Communications”>"Dial Plans'>
"VolP" to apply the Translation Profile and its Translation Rules to
the outbound calls.

% 6 (2] Cisco ¢ ation Professional !l

Configure > Unified Communications > Dial Plans > Vo1P

Plrine | 2 rows retrieved |

¥ E3 Interface Manag: Mol | S——" Destination Tncoming Called  Translation Translation Remaote Site
nterface Management .
Ll Intertace and Connections 1 44+ tncoming cal T [re—"
1) ErmrpyWine 2 Outgeing call ta 5 ST sip-server

» G Router
» 3 Security
¥ 5 unified Communications
) unified Communicatons Features
L Telephony Sattings
) Advanced Teleghony Settings
# i Users, Phones and Extensions
] veIP Settings
v B3 Trunks
3 51P Trunes.
¥ 23 Disl Plans
[yrots

| Calling Restrictions
) Codec Profiles.
» L4 Teiephony Featuras

) Media Resources

4 Configueation Editor
?Save Canfiguration to BC

. write to Startup Configuration
P reinet

Creata... | | wan Dalets
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a. Select the Dial Peer #2 (“Outgoing calls to SIP trunk") and then
click the "Edit" button.

b. Select the “Digit Manipulation” tab from the “EditVolP Dial
Peer" screen.

c. Select the translation profile (“SIP_Trunk_Rules") from the drop-
down list of the “Translation Profile for Outgoing Calls" field.

d. Click the “OK" button.

i tmi7rand= 33404 - Windows Internet Explorer

B - " . -
| 7 Mome | configure | |l monnor w & Cisco Configuration Professional

alvals
(4L 1<
e ————
10.10.10.1 |w b Configure > Unified Communications > Dial Plans > VoIP 7

P —

Dial Peer Tag Tacaming Called | Transiation Transtation Remote Site
Numbers Profis Outgoing  Profils Incomng
: sane
Diait Manipulation  Callg Restrictions
Transiation Profile for Outgoing Calls
Transiation Profile for Incoming Cali
C Contms | [ 80 | [ ot

62. Click the “Deliver" button.

) iams cantigurs |} mona Cisco Configuration Professional

lienls
(4111

1040404 | v

| EdnvolP Dial Peer i
Ceneral Digit Manmpulstion Callng kestrctions

SIP_Trunk_Rules | %

Salact -

running cenfigaration

Faliowing commands wil be appiied to the device's

Brofie cutgoing SIP_Trunk_Rules
oice-class codec 1

Running configuranion wail ba lost uniess i is savad to star up configuration.
Save Current Configuration to PC
Save the configurstion displayed sbove to your BC.

| saveds.. |
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63. Navigate to “Configure'>"View'>"Running Configuration” to see if the

“transfer-pattern 9T" and “transfer-system full-consult” commands are
set up under the “telephony-service” section. If these commands are not
there, you cannot dial the “9" access code to transfer a LAN-to-WAN call
to another WAN phone. To take care of this problem, enter the following
CLI commands from the console:
cisco2901cme#tconfigure terminal
Enter configuration commands, one per line. End with CNTL/Z.
cisco2901cme(config)fttelephony-service
cisco2901cme(config-telephony)#transfer-pattern 9T
cisco2901cme(config-telephony)#transfer-system full-consult
cisco2901cme(config-telephony)#exit
cisco2901cme(config)#exit
cisco2901cme#t

. - . e
Cisco Configuration Professional c”“A

saszwcrd 7 6316769580 reaim 6316769580

&

Note: The Cablevision network only supports inband DTMF tones. The
Cisco CME PBX only supports out-of-band DTMF tones. In order for the
Cisco CME PBX to operate correctly with the Cablevision network, the
Optimum SIP Trunk Adaptor must be configured to convert out-of-band
DTMF tones sent by the Cisco CME PBX to inband DTMF tone.
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64. To enable this conversion, log into the Optimum SIP Trunk Adaptor using
the login and password specified in the Optimum SIP Trunk Adaptor
Set-Up Guide.

a. On the SIP Trunk Configuration page, you must check the “Convert
Inband DTMF" checkbox.
b. Click the “Submit” button to update this setting.

tmﬂum)mnnm\

Help
Configuration SIP Trunk Configuration
Menu
+ Customer Select your PBX: I Cisco Call Manager Express l
*LAN Settings
'% . Passive connection using the local, private IP address of the
* Diagnostics PBX
» System This address must be on the same subnet as the IP Address that is specified
for the LAN interface
PBX Address: 192.168.1.10

Active connection using registration
User 1d:
Password:

I Convert Inband DTMF: I

== e

Status:

Trunk Status: [Regstered

DID's

6316769522 ( Piot number )
6316769523

6316769524
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